Thursday, September 20, 2018

miniSAP - SAP NetWeaver 7.52 SPS1, installation

After release of “miniSAP - SAP NetWeaver 7.51 SPS2” which occurred last year on SAP TechEd 2017 this year the SAP is coming with newer version of ABAP stack which is SAP NetWeaver 7.52 SPS1. It looks like that the SAP is starting a good practice releasing the newest versions of their ABAP servers for developers. This is something that many people are very welcoming including myself. Even in the age of cloud computing the cloud is not solution for everyone (speaking here about cost of running SAP in cloud providers from independed SAP developer perspective or even student).

This year I choose OS openSUSE Leap 15.0 (released on 2018-08-21) is higher OS version as openSUSE Leap 42.3 (released in 2017) for the miniSAP NW752SP01.

As usual installation files can be downloaded from SAP Store. You either look it up directly at https://store.sap.com or go to https://tools.hana.ondemand.com/#abap and find a link to the SAP Store there. Alternatively you can go via https://www.sap.com/developer/trials-downloads.html or to save all the hassle go directly to the page with the files. If you have a troubles with downloading the file like I had (see here) getting an error “You are not authorized to download this file” try to delete cookies or use different web browser.

Again within this release an installation procedure is very well described in blog by Julie Plummer that can be found at SAP AS ABAP 751 SP02 Developer Edition to Download. Therefore, I’m not going to describe the installation step by step. I just focus on one issue that I faced. 

In particular, it was related to license file of ASE database. In case your install fails with error like below: 

ERROR      2018-09-15 18:37:19.273 (root/sapinst) (startInstallation) [CInstallerCallBackImpl.cpp:259] id=ind-rel.ind-os.ind-db.assertionFailed errno=CJS-00030 CInstallerCallBackImpl::abortInstallation()
Assertion failed: Unable to verify database access for login SAPSR3. Refer to trace file sapinst_dev.log for further information

ERROR      2018-09-15 18:37:19.274 (root/sapinst) (startInstallation) [iaxxbjsmod.cpp:83] id=modlib.jslib.caughtException errno=MUT-03025
Caught ESAPinstException in module call: Assertion failed: Unable to verify database access for login SAPSR3. Refer to trace file sapinst_dev.log for further information..

ERROR      2018-09-15 18:37:19.537 (root/sapinst) (startInstallation) 
[CSiStepExecute.cpp:1102] id=controller.stepExecuted errno=FCO-00011 CSiStepExecute::execute()
The step syb_step_login_check with step key |offlineadjustment_dialogs|ind|ind|ind|ind|0|0|offlineadjustment_db_post|ind|ind|ind|ind|db_post|0|syb_rename_db_post_dia|ind|ind|ind|ind|syb|0|NW_SYB_DB_REN|ind|ind|ind|ind|syb2|0|syb_step_login_check was executed with status ERROR (Last error reported by the step: Assertion failed: Unable to verify database access for login SAPSR3. Refer to trace file sapinst_dev.log for further information). 

You need to download correct ASE license file (SYBASE_ASE_TestDrive.lic) from location location and put it to folder /sybase/NPL/SYSAM02_0/licenses. Do not forget to set proper owner of the file (chown sybnpl SYBASE_ASE_TestDrive.lic) and group (chgrp sapsys SYBASE_ASE_TestDrive.lic). The correct license file is valid till March 31st 2020. 

Afterwards restart the installation. Once it is successfully over you shall get a message like this:



Enjoy the newest version of the miniSAP!

More information:

4 comments:

Maxim said...

May be a typo: "the age of could computing" :)

Martin Maruskin said...

thanks Maxim, it is corrected now...

Anonymous said...

Hi,

the link for the correct ASE license file (SYBASE_ASE_TestDrive.lic) from location
does not work for me. dit it change in the last weeks?

Hubert

Martin Maruskin said...

Hi Hubert, pls try to download the license from:
https://blogs.sap.com/2018/08/30/as-abap-7.5x-ase-license-available/